Back
Maintenance

Scheduled Maintenance

Completed 26 Oct at 12:14pm BST.

Completed

Maintenance has been successful

Posted 26 Oct at 12:14pm BST.
Updated

Unfortunately we need to extend the maintenance period by an additional 2 hours to complete the quality analysis of the new updates. Sorry for any inconvenience caused.

Posted 26 Oct at 10:57am BST.
Updated

We will be extending the maintenance window by 1 hour to complete the quality analysis of the new updates. Sorry for any inconvenience caused.

Posted 26 Oct at 09:08am BST.
Started

We will be running a maintenance on Saturday, 26th October 2024, between 5am and 10am. Please note that the application will be offline during the maintenance window.

Posted 26 Oct at 05:00am BST.