Back
Degraded

Performance issue
Started 24 May at 03:35pm BST, resolved 24 May at 04:40pm BST.
Application
Resolved
We have identified the root cause of the issue and have applied a fix. Systems are now back to normal, however, we will continue to monitor. Thank you for your patience.
Posted 24 May at 04:40pm BST.

Created
We are currently experiencing performance issues with our UK platform. We are currently investigating this. Apologies for the inconvenience.
Posted 24 May at 03:35pm BST.